2009-02-09

VirtualBox - Broken Mouse Integration

VirtualBox mouse integration had previously been working for me after i installed Guest Additions (running a Linux guest on a Linux host). But recently, ever since i updated some packages (on the guest machine), it had stopped working.

This baffled and inconvenienced me, and after doing some searching, i found a couple of solutions (from MakeTechEasier and Tombuntu) which involved editing the /etc/X11/xorg.conf file.

The first suggestion is to add the line

Driver "vboxvideo"

to the "Device" section (if that line is not there). In other words, your "Device" section should look like:

Section "Device"
    Identifier "Configured Video Device"
    Driver "vboxvideo"
EndSection


The other possible solution i found is to add a "InputDevice" section to the configuration file (if the section is not present), and to ensure that it uses the "vboxmouse" driver (if the section is already there).

So your xorg.conf file should have an "InputDevice" section like this one:

Section “InputDevice”
    Identifier “Configured Mouse”
    Driver “vboxmouse”
    Option “CorePointer”
EndSection


Both solutions sound logical. Unfortunately, they did not work for me. i stumbled upon the cause when i tried to mount the shared folder in the guest machine and failed (no such device). This led me to conclude that the updates that i did must have broken the Guest Additions installation.

Installing Guest Additions again instantly did the trick for me, and this is something you may want to try if you run into the same problem. If re-installation does not fix it, try examining your xorg.conf, and ensure that the relevant sections look like the ones listed above.

2 comments:

Ed Mazur said...

I was having the same problem after installing updates and this solution worked for me, thank you.

canon said...

Reinstalling the guest additions did the trick for me too.